Back to overview
Downtime
Residential Proxies are unavailable
Feb 6, 2026 at 6:37pm UTC
Affected services
Europe, Amsterdam
North America, New York City
Residential
Resolved
Feb 6, 2026 at 11:31pm UTC
We have fixed the issue. Normally, this would have took a couple minutes, but it was delayed due to issues with external resources.
Affected services
Created
Feb 6, 2026 at 6:37pm UTC
We are aware of the cause, this issue will be fixed within the next few minutes.
Affected services