Back to overview
Downtime
Issue with service provider
Feb 6, 2026 at 7:40am UTC
Affected services
Europe, Amsterdam
Resolved
Feb 6, 2026 at 10:57am UTC
EU-AMS is back online.
Affected services
Created
Feb 6, 2026 at 7:40am UTC
Our service in Europe (Amsterdam) is currently experiencing an outage. We’re monitoring the situation and will provide updates once our service provider resolves the issue.
Affected services