Back to overview
[EU-AMS, NA-LAX] Servers stuck resolving host
Oct 3, 2025 at 4:33pm UTC
Affected services
Europe, Amsterdam
Resolved
Oct 3, 2025 at 4:33pm UTC
All servers get stuck at resolving server address when connecting to a route.
Found cause of the issue, services will be restored shortly. (dns cache issue)
Fixed, all services have been restored.
Affected services